Company Christmas Holidays
North American Headquarters in Miami, USA: Dec 25, 2015, Jan 1st 2016
European Headquarters in Muenster, Germany: Dec 21, 2015 until Jan 03rd 2016
Limited support is available during this period.
We at PROVISIO wish you Merry Christmas and a Happy New Year!

 

Support Request: Sitekiosk not connecting to siteremote after 20H2 update

Description

Our sitekiosk's have updated to Windows 10 20H2 but now won't stay connected to siteremote. If I reboot the sitekiosk it is momentarily connected to siteremote but then loses connection.
The sitekiosk is still usable and are online for the end user but admins have no access to them in siteremote. Sitekiosks are pingable on the network and the c drive can be accessed via c$.

Siteremote gives the following message:
The machine failed to respond to the SiteRemote server within the required interval. Common causes include system crashes or missing network connectivity on the client end.

Kiosks that are still on Windows 10 1909 are accessible through siteremote.

Answer: (7)

Re: Sitekiosk not connecting to siteremote after 20H2 update 4/23/2021 2:53 PM
Hello,

Thank you for your inquiry. Currently SiteKiosk is supported on Windows 10 20H2 and there are no known issues. Something else might be the factor. You can check whether the client computer can access the SiteRemote server via 8086 by using this PowerShell command on the SiteKiosk computer:


 Test-NetConnection siteremote.net -Port 8086 


If you get:

 TcpTestSucceeded : True 


Then check Windows Event Viewer Logs in Application and System for "SiteRemote Client" service failures. The only way for this service to fail is an outside influence on that system (security applications, domain polices, etc). That service runs under user SYSTEM. You can find more at services.msc (Services App) and check Logon As and other settings or try restarting(service) and observe.

If you get:

 TcpTestSucceeded : False  


Then you will need to check the firewall settings for your computer or company network. You can find more about required ports here - https://www.provisio.com/en-US/CustomerSupportCenter/ArticleDetails.aspx?ArticleID=461

Hopefully, this would help identifying the cause.

Best regards,
Andre.
Re: Sitekiosk not connecting to siteremote after 20H2 update 4/23/2021 5:46 PM
Thanks Andre.
The kiosk can access the SiteRemote server via 8086 by using this PowerShell command. We get a result of True.
There are crashes in the application eventviewer for SiteRemoteClientService.exe and .NET Runtime

Log Name: Application
Source: .NET Runtime
Date: 4/23/2021 11:19:59 AM
Event ID: 1026
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: <>
Description:
Application: SiteRemoteClientService.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: exception code c0000005, exception address 1005CE0F

Log Name: Application
Source: Application Error
Date: 4/23/2021 11:19:59 AM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: <>
Description:
Faulting application name: SiteRemoteClientService.exe, version: 1.2.0.193, time stamp: 0x5937e9d1
Faulting module name: cpuidsdk.dll, version: 1.1.3.2, time stamp: 0x56961be1
Exception code: 0xc0000005
Fault offset: 0x0005ce0f
Faulting process id: 0x254
Faulting application start time: 0x01d7385414075f10
Faulting application path: C:\Program Files (x86)\SiteKiosk\SiteRemote\SiteRemoteClientService.exe
Faulting module path: C:\Program Files (x86)\SiteKiosk\SiteRemote\cpuidsdk.dll
Report Id: 2bd7fe90-82f4-4049-b17c-90de8d66fcf7
Faulting package full name:
Faulting package-relative application ID:

Log Name: Application
Source: Windows Error Reporting
Date: 4/23/2021 11:20:00 AM
Event ID: 1001
Task Category: None
Level: Information
Keywords: Classic
User: N/A
Computer: <>
Description:
Fault bucket 109185661559, type 1
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: SiteRemoteClientService.exe
P2: 1.2.0.193
P3: 5937e9d1
P4: cpuidsdk.dll
P5: 1.1.3.2
P6: 56961be1
P7: c0000005
P8: 0005ce0f
P9:
P10:

Attached files:
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER95A0.tmp.mdmp
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER96BB.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER96CB.tmp.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER96D9.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER96EA.tmp.txt

These files may be available here:
\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_SiteRemoteClient_b487b55ffa7065816230b334f59af289c5879981_4a1de21d_4e5fd27f-3ff1-4647-b83a-1a94cc58d5bb

Analysis symbol:
Rechecking for solution: 0
Report Id: 2bd7fe90-82f4-4049-b17c-90de8d66fcf7
Report Status: 268435456
Hashed bucket: f445ce7fb7a4c1b1976e8015dfd476e9
Cab Guid: 0
Re: Sitekiosk not connecting to siteremote after 20H2 update 4/23/2021 5:53 PM
I will add that the SiteRemote Client Startup type is automatic and Logon is the local System account.
I've confirmed our security apps are not blocking it. our kiosks still on 1909 connect to siteremote successfully, its just the newly updates ones to 20H2 seeing this crash.
Re: Sitekiosk not connecting to siteremote after 20H2 update 4/23/2021 7:24 PM
Hello,

Could you please try to manually unregister that SiteKiosk machine from SiteRemote? You will need to delete the SiteRemote config files. Here are the steps:

1. Close the SiteKiosk configuration editor.
2. Login as administration and go to "C:\ProgramData\PROVISIO\SiteRemote Client" (this folder is hidden by default in Windows) and then delete all files that start with "SiteRemoteClient".
3. Go to the list of Windows services("Services.msc") and restart the service name "SiteRemote Client".
4. You can then open the SiteKiosk configuration editor and register SiteKiosk with the SiteRemote Server.

Note: Doing this, you will keep your device data and statistics.

If this does not help in keeping connections with the server, please try reinstalling the software. (Please keep in mind that others have upgraded to 20H2 without any errors, your issue may be environment related.)

Of course, with uninstalling and reinstalling, you would need to back up your files:

Configuration - C:\Program Files (x86)\SiteKiosk\Config (*.skcfg files, ignore *skcfg.local)
Start Screen - C:\Users\Public\SiteKiosk\content (the entire folder).
Media Content - C:\Program Files (x86)\SiteKiosk\Html (images, videos, html folders, PDFs etc.)
SiteKiosk user custom settings - Export & Import (*.swcfg files) using the System-Security-Manager >>Customized option - Section 2.3/4: https://www.provisio.com/helpconsole/SiteKiosk%20Help/en-US/default.htm?welcome.htm

Best regards,
Andre.
Re: Sitekiosk not connecting to siteremote after 20H2 update 4/23/2021 7:39 PM
Hello,

I did not verify your SiteKiosk version. Not long ago, there were certain environments that require ".NET strong name validation". If you are using the latest SiteKiosk, then you should not have that issue. If you have an older version, please try the updated version as a test - https://www.provisio.com/en-US/Downloads/Download.aspx?ItemId=1
A license is not needed for testing but is needed for permanent use. You can find your older version here if you don't plan to update your license soon - https://www.provisio.com/en-US/Downloads/VersionHistory.aspx

Best regards,
Andre.
Pages (2): [1] 2 Next »